Disable multi selection

Some times when I want to select part of a line, another part is selected at the same time.

If I click ESC then the selection cancels and I can select only the part that I wanted.

Is there an option that I can turn off so multiple selections are disabled?

Hi, you probably want to turn off Edit > Preferences > Editing > Smart Editing > Edit matching delimiter on select.

thanks! I’ll try that

I didn’t find that option because the preferences windows is not showing all options (I searched for “smart”, then I saw it)

There was an option to see all available configurations, wasn’t?

Note this behaviour is fixed in the upcoming 10.2.2 release, which you can currently access as a nightly:


I’m not sure what you mean by this?

Komodo 10 shows all preferences, none are hidden any more. In Komodo 9 we hid some preferences but that confused more than helped people so we stopped doing it.

  • Carey

Oh I see what happened, it is related to this issue

I’m sure there is an arrow icon that prompts me to double click to expand, but because I did’t see it, I wasn’t aware that more options where available.