Copy/paste is broken when pasting to other programs

I thought this was a problem with the other program, but it appears that komodo is including a zero-width-space character that breaks other programs not built for it.

For instance, with (chrome) opened, go to prefernces: color scheme in Komodo. Copy the “function (data)” from the example (it should be colorized) and paste it into jsoneditoronline. You’ll get a dot and not the text.

Then repeat the operation just copying the “data” and paste that. It works.

I need my editor to play nice with other programs. I looked for a “copy” setting which might force it to plain text but did not see one.

hey @Scorp1us,

What version of Komodo are you using? If it’s 9.3 nightly, are you able to reproduce in 9.2.1?

I’m not able to reproduce this. What language do you have selected in the Color Schemes window? I tried JS and PHP and they worked fine.

Also, are you able to reproduce this from the editor it’s self? Not to say that the color schemes should be copy incorrect characters, but they are slightly different implementations of a “view” so it would help us narrow it down if we can reproduce the issue.

  • Carey

I’m on Komodo 9.1, I’ve had issues with 9.2, and despite trying it several times, I can’t get 9.2 to work. I’m thinking that 9.3 won’t work for me. Unless you fixed the issue with it not being able to open remote files (yeah, don’t worry about that issue… I think I’m a lost cause there)


You’ll need to try it in 9.2 at least. I’m not aware of an issue with remote files. I use remote files editing on a regular basis so that’s working.

Just so you’re aware, if it’s working in 9.3 we’ll simply recommend you upgrade. We won’t back port a fix. That’s just too much over head to re-release old software.

  • Carey

The issue is I use ssh mounted files (autofs + FUSE). I figured these would look like regular files, but for some reason, 9.2 won’t open. I’ve cleared the settings multiple times and it just won’t do anything but give me a white window with a spinner. After attempting to use it for an hour, I made a rather irate post here that I’m not proud of. Komodo is very good, but I can’t believe I’m having issues with it opening files. I can ‘ls’ and ‘cat’ the files, but Komodo just sits there.

Other issues I see with 9.1 are relatively minor in comparison.

I know it’s hard to revisit moments like that :wink: but could you share the link? Sounds like you’re using OSX which is what I use half the time too so it would be good to revisit it. Fresh heads and what not.

  • Carey

I’m not linking to that.

Ask me what you want, tell me how to get you the information you want, and I’ll answer. Part of my frustration is I don’t know how to debug Komodo, and I think opening files is a relatively easy thing.

I am using OSX, which coupled with our crappy internet here, creates a lot of issues, but I can ls and cat the files, so I don’t know why Komodo can’t open them. Linux seems to be much more fault tolerant. But I’m stuck on OSX because it’s the only OS that can also do iOS and Android development.

FUSE from my understanding is only creating a mount, Komodo should not be aware of there being any difference between a FUSE mounted directory and a regular one (that’s an assumption based on what I know of FUSE, mind you).

Does the issue still persist in 9.3? If so we should get an issue going for this on our bug tracker.

For the issue at hand (copy/paste) I cannot reproduce this on OSX. Few questions:

  • What version of OSX are you on?
  • What browser are you using?
  • Are you using any software that could be interpreting your keypresses in some way?

I think maybe we got these confused (sorry for the pun) the file issue is not related to the paste issue.

Yes, that is my understanding as well. With it mounted, Komodo should be oblivious to the fact that it is remote.

OSX 10.10.3
Chrome Version 45.0.2454.101 (64-bit)
I am using Karabiner, only for remapping ctrl to apple. (Yes, I am remapping ctrl key to apple for copy,paste. However this doesn’t explain why if I copy text without syntax highlighting it works. It also works with syntax highlighting, when staying within Komodo.)

That’s why addressing multiple issues in the same topic is always problematic :slight_smile: Please consider opening another thread for the file issue so we don’t get mixed up.

Really the highlighting should not make any difference, does pasting in other applications give you regular results? eg. TextEdit.

@mitchell pinging you, he’s getting weird clipboard data when copying scintilla code with highlighting, no issues when it’s plan text.

To add to your last comment, it’s all in the same document. It’s only a problem if I cross a text color boundary, which is frequent.

Sorry, I cannot reproduce this on OSX. I copied a range of different highlights from Komodo’s color preferences as you suggested, and pasted into Nothing abnormal there. I also pasted into OSX’s with no issue. Scintilla never includes styling information in clipboard text; it’s all just plain text.