Can't delete debug configuration

I have Komodo IDE 9.3. In the debug options for a Perl script, I am unable to delete a configuration. The first time I tried, it didn’t do anything. After that, it will either want to delete the project configuration or tell me that I can’t delete the default configuration.

How can I get rid of this debug configuration?

I created a debug configuration called “test”, ensured it was selected in the configuration drop down of the debug options dialog, then clicked “delete”. When prompted for confirmation I pressed “Yes”. I still saw the “test” configuration, but cancelled out of the dialog and tried to debug again. Now “test” was gone and I was left with my “default” configuration. Is this not the case for you?

Correct. I attempted to delete it and it still shows up when I debug. If I try to delete it again, it will delete the project configuration or say that it can’t delete the default.

I cannot see your screen, but it sounds like the “default” debug configuration is a lot like whatever configuration you created and then subsequently deleted. Thus it feels like the configuration wasn’t deleted when you tried to do it. When you click the “Delete” button, is the debug configuration name in the drop down something other than “default”?

Here is what I have in my configuration drop down:


If I try to select and try to delete “the_unwanted_configuration”, it will ask me if I want to delete the Project config. If I delete that and try again to delete “the_unwanted_configuration”, it tells me that I can’t delete the default config. If I try to add “the_unwanted_configuration” back, it says that it exists.

The default and “the_unwanted_configuration” are two different configurations with each containing a different list of script arguments.

I finally figured out how to get rid of it. It was not the most intuitive. If I deleted and then cancelled, it didn’t go away. Instead my steps are as follows:

Select “the_unwanted_configuration”, delete it. Select “default” and run the debug.

Now it is gone. I guess by having it selected after I deleted it, caused it to save it again.

Thanks for the follow up. I’m glad you were able to get it sorted out :slight_smile: